配置Client-Initiated场景下的L2TP VPN(本地认证)(vpn拔号时:l2tp配置错误)

配置Client-Initiated场景下的L2TP VPN(本地认证)

sw1_2022.09.18.22时15分08秒.txt

sw2_2022.09.18.22时15分31秒.txt

防火墙_2022.09.18.22时15分47秒.txt

(1)拓扑图

图片.png

(2)基础配置

华为usg防火墙
华为usg防火墙:配置接口
interface GigabitEthernet0/0/0
 undo shutdown
 ip binding vpn-instance default
 ip address 10.12.3.3 255.255.0.0
 service-manage http permit
 service-manage https permit
 service-manage ping permit
 service-manage ssh permit
 service-manage snmp permit
 service-manage telnet permit
 service-manage netconf permit
#
interface GigabitEthernet1/0/0
 undo shutdown
 ip address 192.168.100.254 255.255.255.0
 service-manage http permit
 service-manage https permit
 service-manage ping permit
 service-manage ssh permit
 service-manage snmp permit
 service-manage telnet permit             
 service-manage netconf permit
#
interface GigabitEthernet1/0/1
 undo shutdown
 ip address 192.168.200.254 255.255.255.0
 service-manage http permit
 service-manage https permit
 service-manage ping permit
 service-manage ssh permit
 service-manage snmp permit
 service-manage telnet permit
 service-manage netconf permit
#

把接口加入trust区域:
firewall zone trust
 set priority 85
 add interface GigabitEthernet0/0/0
 add interface GigabitEthernet1/0/0
#
firewall zone untrust
 set priority 5
 add interface GigabitEthernet1/0/1

 配置默认路由:
ip route-static 10.1.1.0 255.255.255.0 192.168.200.1

配置策略允许所有:
security-policy
 default action permit
 
配置AAA:
 aaa
        manager-user admin
            password cipher 密码
            service-type web
            level 15

sw1:
interface GE1/0/0
 undo shutdown
#
interface GE1/0/1
 undo shutdown
 port default vlan 2
#
interface Vlanif1
 ip address 10.1.1.1 255.255.255.0
#
interface Vlanif2
 ip address 192.168.200.1 255.255.255.0
#

sw2:
interface GE1/0/0
 undo shutdown
#
interface Vlanif1
 ip address 192.168.100.100 255.255.255.0
#
ip route-static 0.0.0.0 0.0.0.0 192.168.100.254

(3)配置地址池
如果真实环境中地址池地址和总部内网地址配置在了同一网段,则必须在LNS连接总部网络的接口上开启ARP代理功能,保证LNS可以对总部网络服务器发出的ARP请求进行应答。
ip pool pool1
   section 1 172.16.1.100 172.16.1.199
图片.png

(4)配置业务方案
aaa
  service-scheme l2tp
    ip-pool pool1

(5)配置认证域及其下用户。
    配置认证域。
    如果需要对L2TP接入用户进行基于用户名的策略控制,认证域的接入控制必须包含internet access。

aaa
   domain default
      service-type l2tp

图片.png

配置分支用户及其对应的用户组。

user-manage group /default/research
user-manage user u001
   parent-group /default/research
   password A@bc12345

图片.png

配置VT接口。
interface Virtual-Template1
 ppp authentication-mode pap
 remote service-scheme l2tp
 ip address 172.16.1.1 255.255.255.0
#
firewall zone dmz
 set priority 50
 add interface Virtual-Template1

配置L2TP Group。
l2tp enable
l2tp-group 1
  tunnel password cipher Cjh@12345
  allow l2tp virtual-template 1 remote LAC-name-cjh

图片.png

图片.png

(6)客户端测试

vpn拔号前是ping不通的:

图片.png

PC1进行拔号:

图片.png

图片.png

图片.png

图片.png

解决:

图片.png

再测试:

图片.png

vpn连接上了,但是还是ping不通,因为产生一个优先级级更优先的默认路由。

图片.png

图片.png

解决:不要勾选上,如果勾选上就要配置到达对端网络的明细路由。

图片.png

或者:

图片.png

已经可以ping通

图片.png

图片.png

图片.png

查看:

display l2tp session

图片.png

display l2tp tunnel

图片.png

图片.png


图片.png

display ip pool name pool1 used 

图片.png

图片.png


其他:

vpn拔号时:l2tp配置错误,原因隧道密码配置错误

图片.png

图片.png


1、本站资源长期持续更新,可加入VIP会员、资源全免费。
2、本资源基本为原创,部分来源其他付费资源平台或互联网收集,如有侵权请联系及时处理。
3、本站大部分文章的截图来源实验测试环境,请不要在生产环境中随意模仿,以免带来灾难性后果。
转载请保留出处:  www.zh-cjh.com珠海陈坚浩博客 » 配置Client-Initiated场景下的L2TP VPN(本地认证)(vpn拔号时:l2tp配置错误)

作者: cjh


手机扫一扫,手机上查看此文章:

一切源于价值!

其他
加载中~

未雨绸缪、居安思危!

数据安全、有备无患!

注意操作、数据无价!

一切源于价值!