配置DHCPv6服务器和DHCPv6客户端示例(DHCPv6无状态方式)(无状态地址自动配置SLAAC)

配置DHCPv6服务器和DHCPv6客户端示例(DHCPv6无状态方式)

图片.png

组网需求
如图1所示,SwitchA与SwitchB在同一条链路上。通过部署SwitchA作为DHCPv6服务器、SwitchB作为DHCPv6客户端,实现SwitchB通过路由通告方式获取IPv6地址、通过DHCPv6服务器获取DNS服务器地址的需求。
配置思路
配置思路如下:
在SwitchA上配置DHCPv6服务器功能。实现通过路由通告方式为DHCPv6客户端分配IPv6地址,通过DHCPv6服务器为DHCPv6客户端分配DNS服务器地址。
在SwitchB上配置DHCPv6客户端功能。实现通过路由通告方式获取IPv6地址,通过DHCPv6服务器获取DNS服务器的地址。
配置前请保证DHCPv6服务器与DNS服务器之间路由互通。
终端通过DHCPv6无状态方式获取地址,设备上的地址池只会分配DNS等信息,设备上不能查询用户信息也不会记录相关日志。
操作步骤
1、在SwitchA上配置DHCPv6服务器
# 配置接口的IPv6地址。
<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] ipv6
[SwitchA] vlan 100
[SwitchA-vlan100] quit
[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] port link-type access
[SwitchA-GigabitEthernet1/0/1] port default vlan 100
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface vlanif 100
[SwitchA-Vlanif100] ipv6 enable
[SwitchA-Vlanif100] ipv6 address fc00:3::1/64
[SwitchA-Vlanif100] quit

# 配置IPv6地址池。
[SwitchA] dhcp enable
[SwitchA] dhcpv6 pool pool1
[SwitchA-dhcpv6-pool-pool1] dns-server fc00:4::1
[SwitchA-dhcpv6-pool-pool1] quit

# 配置通过路由通告方式分配IPv6地址,通过DHCPv6服务器分配其他网络参数。
[SwitchA] interface vlanif 100
[SwitchA-Vlanif100] undo ipv6 nd ra halt
[SwitchA-Vlanif100] ipv6 nd autoconfig other-flag
[SwitchA-Vlanif100] dhcpv6 server pool1
[SwitchA-Vlanif100] quit
[SwitchA] quit

2、在SwitchB上配置DHCPv6客户端功能
<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] ipv6
[SwitchB] vlan 100
[SwitchB-vlan100] quit
[SwitchB] interface gigabitethernet 1/0/1
[SwitchB-GigabitEthernet1/0/1] port link-type access
[SwitchB-GigabitEthernet1/0/1] port default vlan 100
[SwitchB-GigabitEthernet1/0/1] quit
[SwitchB] interface vlanif 100
[SwitchB-Vlanif100] ipv6 enable
[SwitchB-Vlanif100] ipv6 address auto global default
[SwitchB-Vlanif100] dhcpv6 client information-request

3、验证配置结果
# 在SwitchA上,通过命令display dhcpv6 pool查看IPv6地址池pool1的配置。

图片.png

# 在SwitchA上,通过命令display ipv6 interface Vlanif 100查看接口VLANIF100的IPv6链路本地地址,以便后续在DHCPv6客户端上查看是否生成了到IPv6网关的缺省路由。

图片.png

# 在SwitchB上,通过命令display dhcpv6 client查看DHCPv6客户端的配置信息。

图片.png

# 在SwitchB上,通过命令display ipv6 interface Vlanif 100查看接口VLANIF100的IPv6配置信息。

图片.png

# 在SwitchB上,通过命令display ipv6 routing-table查看DHCPv6客户端上已经生成了到IPv6网关的缺省路由。

图片.png


IPv6(列表、list、全)ipv6list
http://www.zh-cjh.com/wenzhangguilei/1534.html
文章归类、所有文章列表、LISTLIST
http://www.zh-cjh.com/wangzhangonggao/2195.html

1、本站资源长期持续更新。
2、本资源基本为原创,部分来源其他付费资源平台或互联网收集,如有侵权请联系及时处理。
3、本站大部分文章的截图来源实验测试环境,请不要在生产环境中随意模仿,以免带来灾难性后果。
转载请保留出处:  www.zh-cjh.com珠海陈坚浩博客 » 配置DHCPv6服务器和DHCPv6客户端示例(DHCPv6无状态方式)(无状态地址自动配置SLAAC)

作者: cjh


手机扫一扫,手机上查看此文章:

一切源于价值!

其他
加载中~

未雨绸缪、居安思危!

数据安全、有备无患!

注意操作、数据无价!

一切源于价值!