配置DHCPv6中继示例

配置DHCPv6中继示例

图片.png

组网需求
如图1所示,DHCPv6服务器要为两个网段(fc00:1::/64和fc00:2::/64)的主机动态分配IPv6地址和DNS服务器的地址,且DHCPv6服务器与主机不在同一链路。SwitchA上fc00:1::1/64和fc00:2::1/64分别作为fc00:1::/64和fc00:2::/64网段主机的网关地址。
配置思路
在SwitchA上配置DHCPv6中继功能,通过转发DHCPv6服务器和主机之间的DHCPv6报文,以实现主机动态获取IPv6地址和DNS服务器的地址。
配置前请保证DHCPv6服务器与DNS服务器之间路由互通。
操作步骤
1、配置SwitchA作为DHCPv6中继
# 使能DHCP服务。
<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] dhcp enable
# 配置接口GE1/0/1接口加入VLAN10,接口GE1/0/2接口加入VLAN20,接口GE1/0/3接口加入VLAN30。

[SwitchA] vlan batch 10 20 30
[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] port link-type access
[SwitchA-GigabitEthernet1/0/1] port default vlan 10
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] port link-type trunk
[SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
[SwitchA-GigabitEthernet1/0/2] quit
[SwitchA] interface gigabitethernet 1/0/3
[SwitchA-GigabitEthernet1/0/3] port link-type access
[SwitchA-GigabitEthernet1/0/3] port default vlan 30
[SwitchA-GigabitEthernet1/0/3] quit
# 配置VLANIF接口的IPv6地址。
[SwitchA] ipv6
[SwitchA] interface vlanif 10
[SwitchA-Vlanif10] ipv6 enable
[SwitchA-Vlanif10] ipv6 address fc00:1::1 64
[SwitchA-Vlanif10] quit
[SwitchA] interface vlanif 20
[SwitchA-Vlanif20] ipv6 enable
[SwitchA-Vlanif20] ipv6 address fc00:3::1 64
[SwitchA-Vlanif20] quit
[SwitchA] interface vlanif 30
[SwitchA-Vlanif30] ipv6 enable
[SwitchA-Vlanif30] ipv6 address fc00:2::1 64
[SwitchA-Vlanif30] quit
# 使能DHCPv6中继功能。
[SwitchA] interface vlanif 10
[SwitchA-Vlanif10] dhcpv6 relay destination fc00:3::3
[SwitchA-Vlanif10] quit
[SwitchA] interface vlanif 30
[SwitchA-Vlanif30] dhcpv6 relay destination fc00:3::3
[SwitchA-Vlanif30] quit
# 配置SwitchA作为网关向主机发送RA消息的M和O标志位,实现主机通过DHCPv6方式获取IPv6地址。
[SwitchA] interface vlanif 10
[SwitchA-Vlanif10] undo ipv6 nd ra halt
[SwitchA-Vlanif10] ipv6 nd autoconfig managed-address-flag
[SwitchA-Vlanif10] ipv6 nd autoconfig other-flag
[SwitchA-Vlanif10] quit
[SwitchA] interface vlanif 30
[SwitchA-Vlanif30] undo ipv6 nd ra halt
[SwitchA-Vlanif30] ipv6 nd autoconfig managed-address-flag
[SwitchA-Vlanif30] ipv6 nd autoconfig other-flag
[SwitchA-Vlanif30] quit

2、配置SwitchB作为DHCPv6服务器

<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] dhcp enable
[SwitchB] ipv6
[SwitchB] vlan 20
[SwitchB-vlan20] quit
[SwitchB] interface gigabitethernet 1/0/2
[SwitchB-GigabitEthernet1/0/2] port link-type trunk
[SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
[SwitchB-GigabitEthernet1/0/2] quit
[SwitchB] interface vlanif 20
[SwitchB-Vlanif20] ipv6 enable
[SwitchB-Vlanif20] ipv6 address fc00:3::3 64
[SwitchB-Vlanif20] quit
[SwitchB] dhcpv6 pool pool1
[SwitchB-dhcpv6-pool-pool1] address prefix fc00:1::/64  
[SwitchB-dhcpv6-pool-pool1] excluded-address fc00:1::1
[SwitchB-dhcpv6-pool-pool1] dns-server fc00:4::1
[SwitchB-dhcpv6-pool-pool1] quit
[SwitchB] dhcpv6 pool pool2
[SwitchB-dhcpv6-pool-pool2] address prefix fc00:2::/64  
[SwitchB-dhcpv6-pool-pool2] excluded-address fc00:2::1
[SwitchB-dhcpv6-pool-pool2] dns-server fc00:4::1
[SwitchB-dhcpv6-pool-pool2] quit
[SwitchB] ipv6 route-static :: 0 fc00:3::1

3、配置DHCPv6客户端(PC的操作系统以Windows 7为例)

(1)右击桌面“网络”,单击“属性”,进入“网络和共享中心”窗口。
(2)单击“本地连接”,进入“本地连接状态”窗口。
(3)单击“属性”,进入“本地链接属性”窗口。
(4)选择“Internet协议版本6(TCP/IPv6)”,点击“属性”,进入“Internet协议版本6(TCP/IPv6)属性”窗口,选择“自动获得IPv6地址”和“自动获得DNS服务器地址”,单击“确定”。

4、验证配置结果
# 在SwitchA上使用display dhcpv6 relay命令用来查看DHCPv6中继配置情况。

图片.png

在SwitchB上使用display dhcpv6 pool命令查看DHCPv6地址池的配置信息。
[SwitchB] display dhcpv6 pool

图片.png

# 分别在SwitchB上使用命令display dhcpv6 pool pool1 allocated address和display dhcpv6 pool pool2 allocated address查看DHCPv6地址池的IPv6地址分配情况。
[SwitchB] display dhcpv6 pool pool1 allocated address

图片.png


IPv6(列表、list、全)ipv6list
http://www.zh-cjh.com/wenzhangguilei/1534.html
文章归类、所有文章列表、LISTLIST
http://www.zh-cjh.com/wangzhangonggao/2195.html

1、本站资源长期持续更新。
2、本资源基本为原创,部分来源其他付费资源平台或互联网收集,如有侵权请联系及时处理。
3、本站大部分文章的截图来源实验测试环境,请不要在生产环境中随意模仿,以免带来灾难性后果。
转载请保留出处:  www.zh-cjh.com珠海陈坚浩博客 » 配置DHCPv6中继示例

作者: cjh


手机扫一扫,手机上查看此文章:

一切源于价值!

其他
加载中~

未雨绸缪、居安思危!

数据安全、有备无患!

注意操作、数据无价!

一切源于价值!